<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head >
<meta charset="UTF-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<title>Coronavirus in Minnesota: 12 more deaths; 73 new cases in Mower County | MinnPost</title>
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='all-css-0' href='https://www.minnpost.com/_static/??-eJylktFOwzAMRX8IL1qlgXhAfAryEq8NS+LITof295itwCatoxJvie0cX+fafVTwXBqV5moa+1jUtYGADhZR8JioBBTnOWcuTsU7IeVRPKnzqlMCdE+JGpdVjmVl8Qf3X3BjTi3WK2AsPo1hKghRm9sm9ntIcSsoR6ftmOiuBMuVytogU96S6BCrQ1VqZ+aNNOzEGGBq74ItlEkVezKVStJI4Jy75M9XLWzzI3DHkqEK23cpC2SMyQ8xX02zDIniMSiEXQX0J+YhBpJL0EzJH5rzCN893qlV9HuXOYzJ/NMBhQKGcDwdY+mXvH4z/52yj5ggcc96dVmq4Wug6TyzWGi+G+A20ZbYLPw1IqH0PG2e1b7ml/Xmuesenzbd+hOfDkbM' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='print-css-0' href='https://www.minnpost.com/wp-content/themes/minnpost-largo/print.css?m=1588892050g' type='text/css' media='print' />
<script type='text/javascript' src='https://www.minnpost.com/_static/??-eJzTLy/QTc7PK0nNK9EvyClNz8wr1s8qLE0tqtQtLUhJLEkt0s+CixjrmeoZ6uVm5ullFevok6IzNzO9CCgENMFYzwBqgn2uraGphYWFpZGBiWEWAKGAMFU='></script>
<script>
var minnpost_membership_data = {"member_level_prefix":"member_","current_user":{"can_access":true},"url_access_level":""};
var minnpost_membership_settings = {"ajaxurl":"https:\/\/www.minnpost.com\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://www.minnpost.com/wp-content/plugins/minnpost-membership/assets/js/minnpost-membership-front-end.js?ver=1588892049'></script>
<script>
jQuery(document).ready(function ($) {
					$('.m-form-membership').minnpostMembership();
					$('.m-form-membership').minnpostTrackSubmit();
					$('.m-form-membership').minnpostAmountSelect();
				});
</script>
<script type='text/javascript' src='https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/js/modernizr-custom.min.js?m=1588892050g'></script>
<script defer crossorigin="anonymous" integrity="sha384-ZbbbT1gw3joYkKRqh0kWyRp32UAvdqkpbLedQJSlnI8iLQcFVxaGyrOgOJiDQTTR" src='https://use.fontawesome.com/releases/v5.12.1/js/all.js'></script>
<script type='text/javascript' src='https://www.minnpost.com/wp-content/plugins/arcads-dfp-acm-provider/assets/js/intersection-observer.min.js?m=1588892049g'></script>
<script src='https://www.minnpost.com/wp-content/plugins/arcads-dfp-acm-provider/assets/js/arcads.min.js?ver=1588892049'></script>
<script>
			const arcAds = new ArcAds({
				dfp: {
					id: '1035012',
					collapseEmptyDivs: '1',
				}
			});
			

				window.addLazyLoad = function( ad ) {
					return new Promise( function( resolve, reject ) {
						// The 'ad' argument will provide information about the unit
						var this_ad_id = ad.adId;
						var options    = {
						  rootMargin: '300px 0px'
						}
						// If you do not resolve the promise the advertisement will not display
						function handler( entries, observer ) {
						  for ( entry of entries ) {
						    if ( entry.isIntersecting ) {
						      resolve();
						    }
						  }
						}
						let observer = new IntersectionObserver( handler, options );
						observer.observe( document.getElementById( this_ad_id ) );
					});
				}
				
</script>
<link rel='https://api.w.org/' href='https://www.minnpost.com/wp-json/' />
<link rel="canonical" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/" />
<link rel="alternate" type="application/json+oembed" href="https://www.minnpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.minnpost.com%2Fhealth%2F2020%2F06%2Fthe-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.minnpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.minnpost.com%2Fhealth%2F2020%2F06%2Fthe-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county%2F&#038;format=xml" />

<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<!-- Global site tag (gtag.js) - Google Ads: 976620175 --><script async src="https://www.googletagmanager.com/gtag/js?id=AW-976620175"></script> <script> window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} gtag('js', new Date()); gtag('config', 'AW-976620175'); </script>

<script data-ad-client="ca-pub-1368619780705816" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>		<link rel="manifest" href="https://www.minnpost.com/wp-json/wp/v2/web-app-manifest">
		<meta name="theme-color" content="#801018">
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="mobile-web-app-capable" content="yes">
		<meta name="apple-touch-fullscreen" content="YES">
							<link rel="apple-touch-startup-image" href="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/app-icons/favicon.ico">
		
				<meta name="apple-mobile-web-app-title" content="MinnPost">
		<meta name="application-name" content="MinnPost">
		<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.minnpost.com"><link rel="https://theeventscalendar.com/" href="https://www.minnpost.com/wp-json/tribe/events/v1/" /><style type='text/css'>img#wpstats{display:none}</style>
		<style>
		#wp-admin-bar-item_unpublishd div, #wpadminbar:not(.mobile) #wp-admin-bar-item_unpublishd:hover div {
			text-transform: uppercase;
			background: #b60;
			color: #fff;
		}
	    </style>		<meta property="og:site_name" content="MinnPost">
		<link rel="shortcut icon" href="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/app-icons/favicon.ico?v=1588892050" type="image/x-icon">
		<link rel="icon" type="image/png" sizes="16x16" href="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/app-icons/favicon-16x16.png?v=1588892050">
		<link rel="icon" type="image/png" sizes="32x32" href="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/app-icons/favicon-32x32.png?v=1588892050">
		<link rel="apple-touch-icon" sizes="180x180" href="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/app-icons/apple-touch-icon.png?v=1588892050">
		<link rel="mask-icon" href="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/app-icons/safari-pinned-tab.svg?v=1588892050" color="#801018">
		<meta name="msapplication-TileColor" content="#801018">
		<meta name="msapplication-TileImage" content="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/app-icons/mstile-144x144.png?v=1588892050">
		<meta name="msapplication-config" content="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/app-icons/browserconfig.xml?v=1588892050">
		<meta name="theme-color" content="#ffffff">
		<link rel="alternate" type="application/rss+xml" title="MinnPost articles | RSS Feed" href="https://www.minnpost.com/feed/">
		<meta property="og:locale" content="en_US">
		<meta property="og:url" content="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/">
		<meta name="twitter:site" content="@MinnPost" />
					<meta property="og:title" content="Coronavirus in Minnesota: 12 more deaths; 73 new cases in Mower County | MinnPost">
							<meta name="description" content="MDH also said Wednesday there have been 31,296 total confirmed cases of COVID-19 in Minnesota, up 414 from Tuesday’s count and based on 19,573 new tests.">
			<meta property="og:description" content="MDH also said Wednesday there have been 31,296 total confirmed cases of COVID-19 in Minnesota, up 414 from Tuesday’s count and based on 19,573 new tests.">
			<meta property="twitter:description" content="MDH also said Wednesday there have been 31,296 total confirmed cases of COVID-19 in Minnesota, up 414 from Tuesday’s count and based on 19,573 new tests.">
						<meta property="og:type" content="article">
		<meta property="article:published_time" content="2020-06-17T15:51:19-05:00">
		<meta property="article:modified_time" content="2020-06-17T15:58:49-05:00">
							<meta property="twitter:card" content="summary_large_image">
		
					<meta property="og:image" content="https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png">
			
							
		
		
					<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<!-- Begin WP Analytics Tracking Generator analytics.js code -->
<style>.async-hide { opacity: 0 !important} </style>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga( 'create', 'UA-3385191-1', 'auto' );
	ga( 'require', 'GTM-KRDHJG8' );
			ga( 'set', 'dimension3', '1344447' );
			ga( 'set', 'dimension4', 'Health' );
			ga( 'set', 'dimension1', 'Not Logged In' );
	ga('send', 'pageview');
</script>
<!-- End WP Analytics Tracking Generator analytics.js code -->
</head>

<body class="post-template-default single single-post postid-1344447 single-format-standard tribe-no-js tribe-bar-is-disabled">

	<div class="m-ad-region m-ad-region-leaderboard">
		<div class="o-wrapper">
			<div class="acm-ad ad-leaderboard" id="acm-ad-tag-leaderboard"></div><div><script>arcAds.registerAd({id: 'acm-ad-tag-leaderboard',slotName: 'dfp_default',dimensions: [[728,90],[970,90],[970,250],[300,50],"fluid"],targeting: {"id":"1344447","url_type":"post"},});</script></div>		</div>
	</div>

	<header id="masthead" class="o-header">
		<div class="o-wrapper o-wrapper-site-header">
			<div class="a-site-branding">
		<a class="a-logo a-logo-svg" rel="home" href="https://www.minnpost.com/" title="Return to MinnPost Homepage">
		<picture>
			<source type="image/svg+xml" srcset="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/minnpost-logo.svg">
			<img src="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/logo.png" alt="MinnPost">
		</picture>
	</a>
</div><!-- .a-site-branding -->
			
<div class="m-support-cta m-support-cta-top">
	<h2 class="a-support-tagline">Nonprofit, nonpartisan journalism. Supported by&nbsp;readers.</h2>
			<a class="a-button a-support-button a-support-button-with-heart" href="https://www.minnpost.com/support"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" role="img" title="Heart" class="icon icon-heart" viewBox="0 0 32 28" data-reactid="190"><path d="M16 5s-.516-1.531-1.49-2.51c-1.534-1.542-3.663-2.49-6.01-2.49s-4.472.951-6.01 2.49c-1.539 1.538-2.49 3.663-2.49 6.01s.951 4.472 2.49 6.01l13.51 13.49 13.51-13.49c1.539-1.538 2.49-3.663 2.49-6.01s-.951-4.472-2.49-6.01c-1.538-1.538-3.663-2.49-6.01-2.49s-4.476.948-6.01 2.49c-.974.979-1.49 2.51-1.49 2.51z" data-reactid="191"></path></svg>Donate</a>
	</div>
		</div>
		<div class="o-wrapper o-wrapper-site-navigation">
			<nav id="navigation-primary" class="m-main-navigation">
				<button class="menu-toggle" aria-controls="primary-links" aria-expanded="false">
					<span>Menu</span>
				</button>
				<ul id="primary-links" class="menu"><li class="home"><a href="https://www.minnpost.com">Home</a></li><li><a href="https://www.minnpost.com/politics-policy">Politics & Policy</a></li><li class="active-parent  current-post-ancestor current-post-parent"><a href="https://www.minnpost.com/health">Health</a></li><li><a href="https://www.minnpost.com/education">Education</a></li><li><a href="https://www.minnpost.com/environment">Environment</a></li><li><a href="https://www.minnpost.com/arts-culture">Arts & Culture</a></li><li><a href="https://www.minnpost.com/economy">Economy</a></li><li><a href="https://www.minnpost.com/perspectives">Perspectives</a></li><li><a href="https://www.minnpost.com/newsletters">Newsletters</a></li><li><a href="/events">Events</a></li><li><a href="https://www.minnpost.com/about">About Us</a></li><li class="search"><a href="/?s=">Search</a><form role="search" method="get" class="search-form" action="https://www.minnpost.com/">
	<fieldset>
		<div class="a-input-with-button a-button-sentence">
			<input type="search" class="search-field" placeholder="Search MinnPost" value="" name="s" maxlength="128">
			<input type="submit" class="search-submit" value="Search">
		</div>
	</fieldset>
</form>
</li></ul>			</nav><!-- #site-navigation -->
										<div id="navigation-featured-account-access">
															<nav id="navigation-user-account-access" class="m-secondary-navigation">
						<ul id="user-account-access" class="menu"><li class=" nmr-logged-out"><a href="https://www.minnpost.com/user/login/?redirect_to=/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/">Log In</a></li><li class=" nmr-logged-out"><a href="https://www.minnpost.com/user/register">Create Account</a></li></ul>					</nav><!-- #navigation-user-account-access -->
									</div>
			
		</div>
	</header><!-- #masthead -->

	
	
	<div id="content" class="o-wrapper o-wrapper-content">
	<div id="primary" class="m-layout-primary">
		<main id="main" class="site-main">
			
<article id="post-1344447" class="m-post post-1344447 post type-post status-publish format-standard hentry category-health category-state-government category-uncategorized tag-coronavirus tag-covid-19">

			<div class="m-post-classification">
							<div class="a-breadcrumb"><a href="https://www.minnpost.com/health/">Health</a></div>								</div>
			
	
	<header class="m-entry-header m-entry-header-singular m-entry-header-single">
		<h1 class="a-entry-title">The daily coronavirus update: 12 more deaths in Minnesota; 73 new cases in Mower County</h1>
						<div class="m-entry-share m-entry-share-top">
				<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-custom share-custom-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-email sd-button share-icon" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/?share=custom-1557446851" target="_blank" title="Click to share on Email"><span style="background-image:url(&quot;https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/icons/email.png&quot;);">Email</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1344447" class="share-facebook sd-button share-icon" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1344447" class="share-twitter sd-button share-icon" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>			</div>
			
			
							<div class="m-entry-meta">
					By&nbsp;<a href="https://www.minnpost.com/author/greta-kaul/" title="Posts by Greta Kaul" class="author url fn" rel="author">Greta Kaul</a> | <span class="posted-on"><time class="entry-date published updated" datetime="2020-06-17T15:51:19-05:00">03:51 pm</time></span>				</div>
			
		
	</header><!-- .m-entry-header -->

				<figure class="m-post-image m-post-image-large">
				<img width="640" height="360" src="https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?fit=640%2C360&amp;strip=all" class="attachment-large size-large jetpack-lazy-image" alt="COVID-19" data-lazy-srcset="https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?w=640&amp;strip=all 640w, https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?w=190&amp;strip=all 190w, https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?w=400&amp;strip=all 400w, https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?w=50&amp;strip=all 50w, https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?w=75&amp;strip=all 75w, https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?w=200&amp;strip=all 200w, https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?w=130&amp;strip=all 130w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" data-lazy-src="https://www.minnpost.com/wp-content/uploads/2020/03/coronavirusCDC640.png?fit=640%2C360&amp;strip=all&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />								<figcaption>
											<div class="a-media-meta a-media-credit">Photo: CDC/Alissa Eckert</div>
																<div class="a-media-meta a-media-caption">COVID-19</div>
									</figcaption>
							</figure><!-- .post-image -->
		
	<div class="m-entry-content">
		
	

	<aside class="o-site-message-container wp-message-inserter-message wp-message-inserter-message-post-template-default wp-message-inserter-message-single wp-message-inserter-message-single-post wp-message-inserter-message-postid-1344447 wp-message-inserter-message-single-format-standard wp-message-inserter-message-tribe-no-js wp-message-inserter-message-tribe-bar-is-disabled  wp-message-inserter-message-coronavirus-daily-update-message wp-message-inserter-message-region-above_article_body wp-message-inserter-message-id-849579 wp-message-inserter-message-editor wp-message-inserter-message-0">
		
														<div class="m-wp-insert-message-item m-wp-insert-message-editor m-wp-insert-message-item-0">
						<p style="margin-bottom: 1em;background: #DCF0FA;padding: 1em 0.5em;font-size:.95em"><a href="https://www.minnpost.com/daily-coronavirus-update/">Sign up here</a> to get our daily updates on coronavirus in Minnesota delivered straight to your inbox each afternoon. And go <a href="https://www.minnpost.com/tag/covid-19/">here to see all of MinnPost’s COVID-19 coverage</a>.</p>
											</div>
										</aside>

		<p><i><span style="font-weight: 400;">For the foreseeable future, MinnPost will be providing daily updates on coronavirus in Minnesota, published following the press phone call with members of the Walz administration each afternoon.</span></i></p>
<p><b>Here are the latest updates from June 17, 2020:</b></p>
<ul>
<li><a href="#cases">31,296 confirmed cases; 1,325 deaths</a></li>
<li><a href="#mower">Mower County cases up</a></li>
<li><a href="#testing">Community testing in the Twin Cities continues</a></li>
</ul>
<div class="acm-ad ad-x100" id="acm-ad-tag-x100"></div>
<div><script>arcAds.registerAd({id: 'acm-ad-tag-x100',slotName: 'dfp_default',dimensions: [[300,250]],targeting: {"pos":"x100","id":"1344447","url_type":"post"},prerender: window.addLazyLoad,});</script></div>
<h4 id="cases"><b>31,296 confirmed cases; 1,325 deaths </b></h4>
<p><span style="font-weight: 400;">Twelve more Minnesotans have died of COVID-19, the Minnesota Department of Health said Wednesday, for a total of 1,325. </span></p>
<p><span style="font-weight: 400;">Of the deaths announced Wednesday, one person was over age 100, three people were in their nineties, five people in their eighties, two people in their seventies and one in their sixties. Ten of the 12 deaths announced Wednesday were residents of long-term care facilities. Of the 1,325 COVID-19 deaths in Minnesota, 1,051 have been among long-term care residents.</span></p>
<p><span style="font-weight: 400;">The current death toll only includes Minnesotans with lab-confirmed positive COVID-19 tests.</span></p>
<p><span style="font-weight: 400;">MDH also said Wednesday there have been 31,296 total confirmed cases of COVID-19 in Minnesota. The number of positives is up 414 from Tuesday’s count and is based on 19,573 new tests.</span></p>
<p><span style="font-weight: 400;">That cases and tests are much higher than in days prior reflects a lag in reporting from a private lab, so Wednesday’s numbers reflect some tests that would have normally been reported Friday, Saturday, Sunday and Monday. Looking beyond the reporting glitch, officials said the numbers appear to represent a continuing gradual decline in positive case counts.</span></p>
<p><span style="font-weight: 400;">You can find the seven-day positive case average </span><a href="https://mn.gov/covid19/data/response-prep/dial-back-dashboard.jsp"><span style="font-weight: 400;">here.</span></a></p>
<p><span style="font-weight: 400;">Since the start of the outbreak, 3,689 Minnesotans have been hospitalized and 351 are currently in the hospital, 181 in intensive care. You can find more information about Minnesota&#8217;s current ICU usage and capacity </span><a href="https://mn.gov/covid19/data/response-prep/response-capacity.jsp"><span style="font-weight: 400;">here.</span></a></p>
<div class="acm-ad ad-x101" id="acm-ad-tag-x101"></div>
<div><script>arcAds.registerAd({id: 'acm-ad-tag-x101',slotName: 'dfp_default',dimensions: [[300,250]],targeting: {"pos":"x101","id":"1344447","url_type":"post"},prerender: window.addLazyLoad,});</script></div>
<p><span style="font-weight: 400;">Of the 31,296 confirmed positive cases in Minnesota, 27,404 are believed to have recovered.</span></p>
<p><a href="https://www.health.state.mn.us/diseases/coronavirus/situation.html"><span style="font-weight: 400;">More information on cases can be found here.</span></a></p>
<h4 id="mower"><b>Mower County cases up</b></h4>
<p><span style="font-weight: 400;">Mower County reported 73 new cases of COVID-19 Tuesday and now has the second-highest incidence of cases in the state.</span></p>
<p><span style="font-weight: 400;">MDH officials said they’re working with local public health officials to provide community testing in Austin on Saturday and Sunday, and should be able to offer about 1,000 tests each of those days.</span></p>
<p><span style="font-weight: 400;">Some of the cases are related to large employers in the area — officials did not say which, while others come from community spread.</span></p>
<h4 id="testing"><b>Community testing in the Twin Cities continues</b></h4>
<p><span style="font-weight: 400;">Testing continues at four sites in the Twin Cities near where protesters held demonstrations in the wake of George Floyd’s death.</span></p>
<p><span style="font-weight: 400;">The most recent batch of tests continues to have a positivity rate of about 1 percent. The seven-day average statewide is about 4 percent, </span><a href="https://mn.gov/covid19/data/response-prep/dial-back-dashboard.jsp"><span style="font-weight: 400;">per MDH.</span></a><span style="font-weight: 400;"> The agency said last week it was not surprising that samples from demonstrators had lower positivity rates than the overall state rate because statewide, many are tested because of known exposure. Protesters have been encouraged to get tested because of the potential risk of transmission at demonstrations even if they were asymptomatic, not because of known exposures.</span></p>
<div class="acm-ad ad-x102" id="acm-ad-tag-x102"></div>
<div><script>arcAds.registerAd({id: 'acm-ad-tag-x102',slotName: 'dfp_default',dimensions: [[300,250]],targeting: {"pos":"x102","id":"1344447","url_type":"post"},prerender: window.addLazyLoad,});</script></div>
<p><span style="font-weight: 400;">While officials said it&#8217;s encouraging that cases are not rising quickly in the wake of protests that started more than three weeks ago (the incubation period for COVID-19 is thought to be as long as two weeks), they said it’s too early to draw conclusions; that increases in cases can lag more than one incubation period.</span></p>
<p><span style="font-weight: 400;">Community testing at sites in Minneapolis and St. Paul will continue next Tuesday and Wednesday. More information can be</span><a href="https://www.health.state.mn.us/diseases/coronavirus/testsites.html"><span style="font-weight: 400;"> found here.</span></a></p>
<h4><b>Today on MinnPost</b></h4>
<ul>
<li style="font-weight: 400;"><span style="font-weight: 400;">Gov. Tim Walz is </span><a href="https://www.minnpost.com/state-government/2020/06/walz-pushes-back-on-legislatures-covid-19-aid-package-for-local-governments/"><span style="font-weight: 400;">pushing back on the Legislature’s plan for COVID-19 aid to local governments</span></a></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Go behind the scenes as the </span><a href="https://www.minnpost.com/artscape/2020/06/go-behind-the-scenes-as-mia-our-largest-museum-prepares-to-reopen/"><span style="font-weight: 400;">Minneapolis Institute of Art preps for reopening</span></a></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Asking yourself how long it’s been since this all started? </span><a href="https://www.minnpost.com/health/2020/03/how-long-has-it-been/"><span style="font-weight: 400;">Us too. </span></a></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">As always, </span><a href="https://www.minnpost.com/health/2020/03/tracking-the-minnesota-covid-19-numbers/"><span style="font-weight: 400;">a look at the numbers</span></a><span style="font-weight: 400;"> on the MinnPost COVID-19 dashboard.</span></li>
</ul>
<h4><b>Around the web</b></h4>
<ul>
<li style="font-weight: 400;"><span style="font-weight: 400;">Well, so much for a COVID-19-free China. </span><a href="https://www.pbs.org/newshour/world/new-beijing-outbreak-raises-virus-fears-for-rest-of-world?fbclid=IwAR1EQgT-HMcCsBAmgohAsulBqXU1fDSEotjK--a0RxU11tWGp2FJnDLAlJc"><span style="font-weight: 400;">Beijing has seen cases rise precipitously, from the PBS NewsHour.</span></a></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">The tale of two hair stylists who cut the hair of a combined 140 people while infected with coronavirus — but got nobody sick, likely because everyone was masked, is </span><a href="https://www.washingtonpost.com/business/2020/06/17/masks-salons-missouri/?utm_campaign=wp_main&amp;utm_medium=social&amp;utm_source=twitter"><span style="font-weight: 400;">turning some mask skeptics into believers</span></a><span style="font-weight: 400;">. From the Washington Post.</span></li>
<li style="font-weight: 400;"><a href="https://www.nytimes.com/2020/06/17/upshot/coronavirus-spending-rich-poor.html?action=click&amp;module=Top%20Stories&amp;pgtype=Homepage"><span style="font-weight: 400;">COVID-19 has cut the spending of the rich. Guess who that affects? The poor. </span></a><span style="font-weight: 400;">From the New York Times.</span></li>
</ul>
<p><span style="font-weight: 400;">MDH’s coronavirus website: </span><a href="https://www.health.state.mn.us/diseases/coronavirus/index.html"><span style="font-weight: 400;">https://www.health.state.mn.us/diseases/coronavirus/index.html</span></a></p>
<p><span style="font-weight: 400;">Hotline, 7 a.m. to 7 p.m.: </span><span style="font-weight: 400;">651-201-3920</span></p>
	</div><!-- .m-entry-content -->

				<div class="m-entry-share m-entry-share-bottom">
				<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-custom share-custom-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-email sd-button share-icon" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/?share=custom-1557446851" target="_blank" title="Click to share on Email"><span style="background-image:url(&quot;https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/icons/email.png&quot;);">Email</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1344447" class="share-facebook sd-button share-icon" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1344447" class="share-twitter sd-button share-icon" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>			</div>
			
			
	

	<aside class="o-site-message-container wp-message-inserter-message wp-message-inserter-message-post-template-default wp-message-inserter-message-single wp-message-inserter-message-single-post wp-message-inserter-message-postid-1344447 wp-message-inserter-message-single-format-standard wp-message-inserter-message-tribe-no-js wp-message-inserter-message-tribe-bar-is-disabled  wp-message-inserter-message-covid19-end-of-story-message wp-message-inserter-message-region-article_bottom wp-message-inserter-message-id-1246193 wp-message-inserter-message-editor wp-message-inserter-message-1">
		
														<div class="m-wp-insert-message-item m-wp-insert-message-editor m-wp-insert-message-item-0">
						<div style="background: #ffffff;padding: 1em;font-size: 1.2em;line-height: 1.4em">
<h2 style="margin-bottom: 0.75em">Coronavirus in Minnesota: What you need to know</h2>
<p><b>The latest</b>: Find <a href="https://www.minnpost.com/tag/covid-19/">all of MinnPost’s coronavirus coverage here</a> and sign up <a href="https://www.minnpost.com/daily-coronavirus-update/">for our daily coronavirus newsletter</a>.</p>
<p><b>More from MinnPost: </b> <a href="https://www.minnpost.com/health/2020/03/tracking-the-minnesota-covid-19-numbers/">Tracking Minnesota’s coronavirus numbers</a> | <a href="https://www.minnpost.com/health/2020/05/minnesota-has-updated-its-covid-19-model-heres-what-it-tells-us/">About Minnesota’s model for predicting cases of COVID-19</a> | <a href="https://www.minnpost.com/health/2020/03/how-can-an-asymptomatic-person-still-spread-the-coronavirus/">How an asymptomatic person can still spread coronavirus</a> | <a href="https://www.minnpost.com/health/2020/03/how-long-has-it-been/">How long has this been going on?</a></p>
<p><b>Community resources</b>: <a href="https://www.health.state.mn.us/diseases/coronavirus/index.html">state of Minnesota’s COVID-19 website</a> | <a href="https://www.cdc.gov/coronavirus/2019-ncov/prevent-getting-sick/prevention.html">How to protect yourself and others</a> | <a href="https://mn.gov/covid19/for-minnesotans/volunteer/">volunteer opportunities</a> | <a href="https://www.mprnews.org/story/2020/03/16/here-are-some-ways-to-help-others-during-the-pandemic">other ways to help</a></p>
</div>
											</div>
										</aside>


	

	<aside class="o-site-message-container wp-message-inserter-message wp-message-inserter-message-post-template-default wp-message-inserter-message-single wp-message-inserter-message-single-post wp-message-inserter-message-postid-1344447 wp-message-inserter-message-single-format-standard wp-message-inserter-message-tribe-no-js wp-message-inserter-message-tribe-bar-is-disabled  wp-message-inserter-message-email-form-article-bottom wp-message-inserter-message-region-article_bottom wp-message-inserter-message-id-676523 wp-message-inserter-message-editor wp-message-inserter-message-2">
		
														<div class="m-wp-insert-message-item m-wp-insert-message-editor m-wp-insert-message-item-0">
						<h3>Get MinnPost in your email inbox:</h3>
<form action="https://www.minnpost.com/wp-admin/admin-post.php" method="post" class="m-form m-form-instory m-form-minnpost-form-processor-mailchimp">
	<input type="hidden" name="minnpost_form_processor_mailchimp_nonce" value="82acba9e4c">
			<input type="hidden" name="user_id" value="0">
		<input type="hidden" name="mailchimp_user_id" value="">
		<input type="hidden" name="first_name" value="">
		<input type="hidden" name="last_name" value="">
						<input type="hidden" name="action" value="newsletter_form">
				<input type="hidden" name="redirect_url" value="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/">
			<div class="m-form-container">
						<div class="m-form-message m-form-message-ajax m-form-message-ajax-placeholder"></div>		<fieldset>
			<div class="a-input-with-button a-button-sentence">
				<input type="email" name="email" value="" placeholder="Your email address" required>
				<button type="submit" name="subscribe" class="a-button a-button-next a-button-choose">Sign up</button>
			</div>
		</fieldset>
			</div>
</form>

<p>You can also <a href="/newsletters/">learn about all our free newsletter options</a>.</p>
											</div>
										</aside>

	
	
	<aside class="a-related-tags"><h4>Related Tags:</h4><ul><li><a href="https://www.minnpost.com/tag/coronavirus/" rel="tag">coronavirus</a></li><li><a href="https://www.minnpost.com/tag/covid-19/" rel="tag">COVID-19</a></li></ul></aside>
		<aside class="m-author-info m-author-info-excerpt m-author-info-singular m-author-info-single">
		<h3 class="a-about-author">About the author:</h3>
		<figure class="a-archive-figure a-author-figure a-author-figure-author-teaser"><img src="https://www.minnpost.com/wp-content/uploads/sites/default/files/imagecache/author_photo/images/author/GretaKaul225.png?fit=75%2C9999&amp;strip=all" class="attachment-author-teaser size-author-teaser jetpack-lazy-image" alt="" data-lazy-src="https://www.minnpost.com/wp-content/uploads/sites/default/files/imagecache/author_photo/images/author/GretaKaul225.png?fit=75%2C9999&amp;strip=all&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><figcaption class="a-author-bio"><h3 class="a-author-title"><a href="https://www.minnpost.com/author/greta-kaul/">Greta Kaul</a></h3><p>Greta Kaul is MinnPost's data reporter. She can be reached at gkaul@minnpost.com.</p>
</figcaption></figure><!-- .author-figure -->	</aside><!-- .m-author-info -->
		
	
<section id="comments" class="o-comments-area o-comments-area-post">

				<h3 class="a-comments-title">No comments yet</h3>
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="a-comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://www.minnpost.com/user/login/?redirect_to=https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-12-more-deaths-in-minnesota-73-new-cases-in-mower-county/">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	</section><!-- #comments -->

</article><!-- #post-## -->
		</main><!-- #main -->
	</div><!-- #primary -->


	
<aside id="secondary" class="o-site-sidebar" role="complementary">
	<div class="m-ad-region m-ad-region-sidebar">
		<div class="acm-ad ad-halfpage-default" id="acm-ad-tag-halfpage-default"></div><div><script>arcAds.registerAd({id: 'acm-ad-tag-halfpage-default',slotName: 'dfp_default',dimensions: [[300,600]],targeting: {"id":"1344447","url_type":"post"},});</script></div>	</div>

	
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x01">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x02">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x03">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x04">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x05">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x06">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x07">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x08">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x09">
				<script type="text/javascript" src=""></script>			</div>
						<div class="m-ad-region m-ad-region-sidebar m-ad-region-x10">
				<script type="text/javascript" src=""></script>			</div>
									<section id="most-commented-widget-2" class="m-widget m-widget-most-commented"><h3 class="a-widget-title">Most Commented Stories</h3><div class="m-widget-contents"><ul><li><a href="https://www.minnpost.com/eric-black-ink/2020/06/hugh-hewitt-stands-up-for-two-of-the-most-undemocratic-provisions-in-the-constitution/">Hugh Hewitt stands up for two of the most undemocratic provisions in the Constitution</a> (58)</li><li><a href="https://www.minnpost.com/eric-black-ink/2020/06/the-popular-vote-loser-has-won-the-u-s-presidency-five-times/">The popular vote loser has won the U.S. presidency five times</a> (45)</li><li><a href="https://www.minnpost.com/eric-black-ink/2020/06/new-media-trumpism-have-undermined-the-values-of-objective-journalism/">New media, Trumpism have undermined the values of 'objective' journalism</a> (36)</li><li><a href="https://www.minnpost.com/state-government/2020/06/from-reforming-the-police-to-curtailing-the-governors-powers-minnesotas-house-and-senate-have-vastly-different-priorities-for-special-session/">From reforming the police to curtailing the governor's powers, Minnesota's House and Senate have vastly different priorities for special session</a> (32)</li><li><a href="https://www.minnpost.com/community-voices/2020/06/christopher-columbus-not-the-man-we-learned-about-as-schoolchildren/">Christopher Columbus: Not the man we learned about as schoolchildren</a> (25)</li></ul></div></section><section id="rpwe_widget-34" class="m-widget m-widget-rpwe-widget m-widget-recent-posts-extended"><h3 class="a-widget-title">Recent Posts</h3><div class="m-widget-contents rpwe-block"><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/letters/2020/06/letter-submission-jim-schuelke-06-16-2020/" title="Permalink to Approve Line 3 and put people to work" rel="bookmark">Approve Line 3 and put people to work</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-25-more-deaths-number-of-new-cases-in-minnesota-rises-for-third-straight-day/" title="Permalink to The daily coronavirus update: 25 more deaths; number of new cases in Minnesota rises for third straight day" rel="bookmark">The daily coronavirus update: 25 more deaths; number of new cases in Minnesota rises for third straight day</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-9-more-deaths-decline-in-new-cases-continues/" title="Permalink to The daily coronavirus update: 9 more deaths; decline in new cases continues" rel="bookmark">The daily coronavirus update: 9 more deaths; decline in new cases continues</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-lowest-number-of-new-reported-deaths-since-april/" title="Permalink to The daily coronavirus update: Lowest number of new reported deaths since April" rel="bookmark">The daily coronavirus update: Lowest number of new reported deaths since April</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/eric-black-ink/2020/06/new-media-trumpism-have-undermined-the-values-of-objective-journalism/" title="Permalink to New media, Trumpism have undermined the values of &#8216;objective&#8217; journalism" rel="bookmark">New media, Trumpism have undermined the values of &#8216;objective&#8217; journalism</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/mental-health-addiction/2020/06/with-igf-kids-irreducible-grace-foundation-hopes-to-teach-children-key-self-care-strategies/" title="Permalink to With IGF Kids, Irreducible Grace Foundation hopes to teach children key self-care strategies" rel="bookmark">With IGF Kids, Irreducible Grace Foundation hopes to teach children key self-care strategies</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/mnopedia/2020/06/the-minnesota-eights-attempts-to-destroy-draft-files-during-the-vietnam-war-were-mostly-unsuccessful/" title="Permalink to The Minnesota Eight’s attempts to destroy draft files during the Vietnam War were mostly unsuccessful" rel="bookmark">The Minnesota Eight’s attempts to destroy draft files during the Vietnam War were mostly unsuccessful</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/second-opinion/2020/06/cdcs-covid-guidelines-for-going-out-face-masks-distancing-and-planning-ahead/" title="Permalink to CDC&#8217;s COVID guidelines for going out: face masks, distancing and planning ahead" rel="bookmark">CDC&#8217;s COVID guidelines for going out: face masks, distancing and planning ahead</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-15-more-deaths-299-more-confirmed-cases/" title="Permalink to The daily coronavirus update: 15 more deaths; 299 more confirmed cases" rel="bookmark">The daily coronavirus update: 15 more deaths; 299 more confirmed cases</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/health/2020/06/the-daily-coronavirus-update-9-more-deaths-30172-total-confirmed-cases/" title="Permalink to The daily coronavirus update: 9 more deaths; 30,172 total confirmed cases" rel="bookmark">The daily coronavirus update: 9 more deaths; 30,172 total confirmed cases</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/state-government/2020/06/trio-of-lawsuits-challenge-minnesota-absentee-balloting-requirements-amid-covid-19/" title="Permalink to Trio of lawsuits challenge Minnesota absentee balloting requirements amid COVID-19" rel="bookmark">Trio of lawsuits challenge Minnesota absentee balloting requirements amid COVID-19</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/artscape/2020/06/roque-diaz-making-music-education-more-inclusive-and-diverse/" title="Permalink to Roque Diaz: Making music education more inclusive and diverse" rel="bookmark">Roque Diaz: Making music education more inclusive and diverse</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/second-opinion/2020/06/certain-personality-traits-linked-to-stockpiling-of-toilet-paper-study-finds/" title="Permalink to Certain personality traits linked to stockpiling of toilet paper, study finds" rel="bookmark">Certain personality traits linked to stockpiling of toilet paper, study finds</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/macro-micro-minnesota/2020/06/rebuilding-lake-street-lessons-from-plymouth-avenue-in-1967/" title="Permalink to Rebuilding Lake Street: Lessons from Plymouth Avenue in 1967" rel="bookmark">Rebuilding Lake Street: Lessons from Plymouth Avenue in 1967</a></p></li><li class="rpwe-li rpwe-clearfix"><p class="a-post-title a-spill-item-title"><a href="https://www.minnpost.com/health/2020/06/what-the-minnesota-health-department-hopes-to-learn-from-covid-19-blood-tests/" title="Permalink to What the Minnesota Health Department hopes to learn from COVID-19 blood tests" rel="bookmark">What the Minnesota Health Department hopes to learn from COVID-19 blood tests</a></p></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></section>		</aside><!-- #secondary -->

	</div>

	<footer id="site-footer" class="o-footer">

		<div class="o-wrapper o-wrapper-site-footer">

			<aside class="o-footer-hat">
				<section id="custom_html-65" class="m-widget m-widget-text m-widget-custom-html m-widget-sponsor-list"><h3 class="a-widget-title">Thanks to our major sponsors</h3><div class="m-widget-contents m-textwidget m-custom-html-widget"><ul class="a-sponsor-list a-sponsor-list-columns-one"><li class="a-sponsor"><a href="https://greatriverenergy.com/"><figure><img width="136" height="63" src="https://www.minnpost.com/wp-content/uploads/2019/02/GRE_Logo_H_Stack.jpg" class="attachment-sponsor-thumbnail size-sponsor-thumbnail jetpack-lazy-image" alt="Great River Energy logo" location="footer" data-lazy-srcset="https://www.minnpost.com/wp-content/uploads/2019/02/GRE_Logo_H_Stack.jpg?w=136&amp;strip=all 136w, https://www.minnpost.com/wp-content/uploads/2019/02/GRE_Logo_H_Stack.jpg?w=50&amp;strip=all 50w, https://www.minnpost.com/wp-content/uploads/2019/02/GRE_Logo_H_Stack.jpg?w=75&amp;strip=all 75w, https://www.minnpost.com/wp-content/uploads/2019/02/GRE_Logo_H_Stack.jpg?w=130&amp;strip=all 130w" data-lazy-sizes="(max-width: 136px) 100vw, 136px" data-lazy-src="https://www.minnpost.com/wp-content/uploads/2019/02/GRE_Logo_H_Stack.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></figure></a></li><li class="a-sponsor"><a href="http://www.ucare.org"><figure><img width="150" height="40" src="https://www.minnpost.com/wp-content/uploads/2019/02/ucare-1.png" class="attachment-sponsor-thumbnail size-sponsor-thumbnail jetpack-lazy-image" alt="UCare logo" location="footer" data-lazy-srcset="https://www.minnpost.com/wp-content/uploads/2019/02/ucare-1.png?w=150&amp;strip=all 150w, https://www.minnpost.com/wp-content/uploads/2019/02/ucare-1.png?w=50&amp;strip=all 50w, https://www.minnpost.com/wp-content/uploads/2019/02/ucare-1.png?w=75&amp;strip=all 75w, https://www.minnpost.com/wp-content/uploads/2019/02/ucare-1.png?w=130&amp;strip=all 130w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://www.minnpost.com/wp-content/uploads/2019/02/ucare-1.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></figure></a></li><li class="a-sponsor"><a href="http://www.ywcampls.org"><figure><img width="136" height="68" src="https://www.minnpost.com/wp-content/uploads/2018/09/YWCAsmlogo.gif" class="attachment-sponsor-thumbnail size-sponsor-thumbnail jetpack-lazy-image" alt="" location="footer" data-lazy-src="https://www.minnpost.com/wp-content/uploads/2018/09/YWCAsmlogo.gif?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></figure></a></li><li class="a-sponsor"><a href="https://www.minnpost.com/community-sketchbook"><figure><img width="150" height="49" src="https://www.minnpost.com/wp-content/uploads/2019/02/mplssmall032018.jpg" class="attachment-sponsor-thumbnail size-sponsor-thumbnail jetpack-lazy-image" alt="Minneapolis Foundation logo" location="footer" data-lazy-srcset="https://www.minnpost.com/wp-content/uploads/2019/02/mplssmall032018.jpg?w=150&amp;strip=all 150w, https://www.minnpost.com/wp-content/uploads/2019/02/mplssmall032018.jpg?w=50&amp;strip=all 50w, https://www.minnpost.com/wp-content/uploads/2019/02/mplssmall032018.jpg?w=75&amp;strip=all 75w, https://www.minnpost.com/wp-content/uploads/2019/02/mplssmall032018.jpg?w=130&amp;strip=all 130w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://www.minnpost.com/wp-content/uploads/2019/02/mplssmall032018.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></figure></a></li><li class="a-sponsor"><a href="https://ottobremer.org/"><figure><img width="150" height="50" src="https://www.minnpost.com/wp-content/uploads/2019/02/obt.png" class="attachment-sponsor-thumbnail size-sponsor-thumbnail jetpack-lazy-image" alt="Otto Bremer Trust logo" location="footer" data-lazy-srcset="https://www.minnpost.com/wp-content/uploads/2019/02/obt.png?w=150&amp;strip=all 150w, https://www.minnpost.com/wp-content/uploads/2019/02/obt.png?w=50&amp;strip=all 50w, https://www.minnpost.com/wp-content/uploads/2019/02/obt.png?w=75&amp;strip=all 75w, https://www.minnpost.com/wp-content/uploads/2019/02/obt.png?w=130&amp;strip=all 130w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://www.minnpost.com/wp-content/uploads/2019/02/obt.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></figure></a></li></ul><h3 class="a-heading-donor-thanks">Additional thanks to our <a href="/major-supporters/">top philanthropic supporters</a>.</h3></div></section>
<section id="custom_html-70" class="m-widget m-widget-text m-widget-custom-html"><div class="m-widget-contents m-textwidget m-custom-html-widget"><div class="a-site-branding">
	<a class="a-logo a-logo-svg" rel="home" href="https://www.minnpost.com/" title="MinnPost">
		<picture>
			<source type="image/svg+xml" srcset="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/minnpost-logo.svg">
			<img src="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/logo.png" alt="MinnPost" data-lazy-src="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/logo.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://www.minnpost.com/wp-content/themes/minnpost-largo/assets/img/logo.png" alt="MinnPost"></noscript>
		</source></picture>
	</a>
</div><!-- .a-site-branding -->
<p class="a-tagline-bottom">is a 501(c)(3) nonprofit newsroom</p></div></section>
				
<section class="m-support-cta m-support-cta-bottom">
				<header class="m-membership-intro m-membership-support-intro">
			<h1 class="a-standalone-title">Support MinnPost’s nonprofit journalism</h1>
		</header>
		<form action="https://support.minnpost.com/give/" method="get" class="m-form m-form-membership m-form-membership-support">
					<p><span style="font-weight: 400;">Member donations are crucial to the work of our nonprofit newsroom. Our reporters are only able to do their work thanks to support at all levels.</span></p>
				<section class="m-membership-fast-select">
			<fieldset>
				<div class="m-form-item-wrap">
										<span class="a-fast-select-currency">&dollar;</span>
					<div id="amount-item" class="m-form-item">
												<input id="amount" min="1" name="amount" value="15" type="number">
					</div>
																<div class="m-form-radios">
																							<div class="m-form-item">
									<input type="radio" name="frequency" value="monthly" checked id="frequencies-1">
									<label for="frequencies-1" class="a-frequency-option">Monthly</label>
								</div>
																							<div class="m-form-item">
									<input type="radio" name="frequency" value="yearly" id="frequencies-2">
									<label for="frequencies-2" class="a-frequency-option">Yearly</label>
								</div>
																							<div class="m-form-item">
									<input type="radio" name="frequency" value="one-time" id="frequencies-3">
									<label for="frequencies-3" class="a-frequency-option">One Time</label>
								</div>
													</div>
									</div>
			</fieldset>
		</section>

		<div class="m-form-actions m-membership-form-actions">
			<button type="submit" name="give" class="a-button">Donate</button>
		</div>

	</form>

</section>
			</aside>

			<aside class="o-footer-links">
				<nav id="footer-primary" class="m-secondary-navigation">
					<ul id="footer-primary-links" class="menu"><li><a href="https://www.minnpost.com/about">About Us</a></li><li><a href="https://www.minnpost.com/advertise">Advertise</a></li><li><a href="https://www.minnpost.com/support">Membership</a></li><li><a href="https://www.minnpost.com/help">Help</a></li><li><a href="https://www.minnpost.com/contact-us">Contact</a></li><li><a href="https://www.minnpost.com/minnpost-code-of-ethics">Code of Ethics</a></li><li><a href="https://www.minnpost.com/terms-of-use">Terms of Use</a></li><li><a href="https://www.minnpost.com/privacy">Privacy Policy</a></li></ul>				</nav><!-- #footer-primary -->

				<nav id="footer-network" class="m-secondary-navigation">
					<ul id="minnpost-network" class="menu"><li class="twitter"><a href="https://twitter.com/MinnPost">Twitter</a></li><li class="facebook"><a href="https://www.facebook.com/MinnPost">Facebook</a></li><li class="instagram"><a href="https://www.instagram.com/MinnPost">Instagram</a></li><li class="rss-feeds-list"><a href="https://www.minnpost.com/rss-feed-list">RSS Feeds List</a></li></ul>				</nav><!-- #footer-network -->

									<p class="a-footer-message">MinnPost | P.O. Box 18438 | Minneapolis, MN 55418-4714 | <a href="tel:612.455.6950">612.455.6950</a></p>
				
			</aside>

			<a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=www.minnpost.com" rel="generator nofollow" class="powered-by-wpcom"><img src="https://www.minnpost.com/wp-content/mu-plugins/vip-helpers/images/vip-powered-dark-small.png" width="187" height="26" alt="Powered by WordPress.com VIP" /></a>
		</div>
	</footer>

		<script type="text/javascript">
						var _sf_async_config={};
			_sf_async_config.uid = 27923;
			_sf_async_config.domain = "minnpost.com";
			_sf_async_config.useCanonical = true;
				(function(){
			        function loadChartbeat() {
					window._sf_endpt=(new Date()).getTime();
					var e = document.createElement('script');
					e.setAttribute('language', 'javascript');
					e.setAttribute('type', 'text/javascript');
					e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
					document.body.appendChild(e);
				  }
				  var oldonload = window.onload;
				  window.onload = (typeof window.onload != 'function') ?
					 loadChartbeat : function() { try { oldonload(); } catch (e) { loadChartbeat(); throw e} loadChartbeat(); };
				})();
		</script>
<script>
/* <![CDATA[ */
var google_conversion_id = 1002275927;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script src="//www.googleadservices.com/pagead/conversion.js"></script>
<noscript>
<div style="display:inline;"><img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/1002275927/?value=0&guid=ON&script=0"></div>
</noscript>

<!-- Quantcast Tag -->
<script>
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-ddPr1r_sBVpOs"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-ddPr1r_sBVpOs.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<!--
Start Here
Tag: MinnPost - Audience
URL: https://www.minnpost.com/
-->
<script>
var axel = Math.random() + "";
var a = axel * 10000000000000;
document.write('<div style="display:none;"><img src="https://ad.doubleclick.net/ddm/activity/src=9728734;type=invmedia;cat=minnp0;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=;npa=;ord=' + a + '?" width="1" height="1" alt=""/></div>');
</script>
<noscript>
<div style="display:inline;"><img src="https://ad.doubleclick.net/ddm/activity/src=9728734;type=invmedia;cat=minnp0;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=;npa=;ord=1?" width="1" height="1" alt=""/></div>
</noscript>
<!-- End of Part A: Please do not remove -->
<script src="//action.dstillery.com/orbserv/nsjs?adv=cl1027077&ns=4004&nc=MNP-001&ncv=20&dstOrderId=[OrderId]&dstOrderAmount=[OrderAmount]"></script>
<!-- End of Part B: Please do not remove -->		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		
<!-- Schema & Structured Data For WP v1.9.41.2 - -->
<script type="application/ld+json" class="saswp-schema-markup-output">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</script>

<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><!-- Jetpack Search took 96 ms, ES time 5 ms -->	<script>
		if ( navigator.serviceWorker ) {
			window.addEventListener( 'load', function() {
									{
						navigator.serviceWorker.register(
							"\/?wp_service_worker=1",
							{"scope":"\/"}						).then( reg => {
													} );
					}
							} );
		}
	</script>
	<script>
var analytics_tracking_settings = {"analytics_type":"analyticsjs","scroll":{"enabled":true,"minimum_height":0,"percentage":"true","user_timing":"true","pixel_depth":"true","non_interaction":"true","scroll_elements":".ad-middle, .ad-x100, .ad-x101, .m-form-instory, #comments, #footer, .ad-middle3, .ad-right1, .ad-bottomright, .ad-x01, .ad-x02, .ad-x03, .ad-x04, .ad-x05, .ad-x06, .ad-x07, .ad-x08, .ad-x09, .ad-x10"},"special":{"enabled":true,"download_regex":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"fragment":{"enabled":true},"form_submissions":{"enabled":true},"track_adblocker":{"enabled":true}};
</script>
<script>
var params = {"ajaxurl":"https:\/\/www.minnpost.com\/wp-admin\/admin-ajax.php","gtag_sendto":"AW-976620175\/jqCyCL7atXkQj5XY0QM"};
</script>
<script>
var params = {"ajaxurl":"https:\/\/www.minnpost.com\/wp-admin\/admin-ajax.php"};
</script>
<script type='text/javascript' src='https://www.minnpost.com/_static/??-eJyFkeFKQzEMhV/IrAwV9If4KJL1Zr25Nmlpcxnz6Q2yixXc9qclbc75TtpwqhCLGqkFWaHmNbH2sJBVjJ/hgzWGw8p5CnUuVvSy7YR1t/SHMMg3rR+hYj4bxw7W3IY1QSKlhlZawN7JHHG3E47NrYF0uoMT6h0TgZfUjNpljL+kK00D5ArA2VpLNziWJlBbie7k6QQ5x5mlDpybiW0mD/Hrl7GlMoi3i/+0t/8m49cZWHy8H6OhHL28P68TbQ9CcqAt57u87Z9f9y+Pvj4t33f7yNk='></script>
<script>
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
</script>
<script src='https://www.minnpost.com/wp-content/mu-plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.6.1'></script>
<script>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202025.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'150509612',post:'1344447',tz:'-5',srv:'www.minnpost.com'} ]);
	_stq.push([ 'clickTrackerInit', '150509612', '1344447' ]);
</script>

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"51a9741afb","applicationID":"191772526","transactionName":"MVVVZ0dZC0ZYUE0PWAgfdlBBUQpbFkBQCFAKVQ==","queueTime":0,"applicationTime":810,"atts":"HRJCEQ9DGBkbUhtcTBtN","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>




	<aside class="o-site-message-container wp-message-inserter-message wp-message-inserter-message-post-template-default wp-message-inserter-message-single wp-message-inserter-message-single-post wp-message-inserter-message-postid-1344447 wp-message-inserter-message-single-format-standard wp-message-inserter-message-tribe-no-js wp-message-inserter-message-tribe-bar-is-disabled  wp-message-inserter-message-coronavirus-membership-toaster-2 wp-message-inserter-message-region-popup wp-message-inserter-message-id-1281789 wp-message-inserter-message-banner wp-message-inserter-message-1" data-close-time-days="5">
		
			
			<div class="m-wp-insert-message-item m-wp-insert-message-item-0 m-wp-insert-message-item-banner" style="background: linear-gradient(
				#fffca3,
				#fffca3
			);color: #1a225d;max-width:100%;">

									<!-- Dual Col -->
					<div class="dual-wrap ">
						
						<div class="col">
							
	<h3>Trustworthy news. No paywall.</h3>
	<p>Your donation supports in-depth, local coronavirus coverage that is free and accessible to all. <strong>Will you join us?</strong></p>
													</div>
						<div class="col">
															
				<a class="a-button" style="background: #1a225d;color: #ffffff;" href="https://www.minnpost.com/support?campaign=7012I000001JgmrQAC&source=2">
							<i class="fas fa-heart" aria-hidden="true"></i>
										DONATE NOW					</a>
															
						</div>
					</div>
				
													<a href="#" class="sm-close-btn" aria-label="Close" style="color: #1a225d;"><i class="far fa-times-circle" aria-hidden="true"></i></i></a>
							</div>
			</aside>
